今まで玄箱で使用してきたディストリビューションはVineLinux2.6だったのだが、
サポート終了したこともあり、MySQL導入の為に3.1にアップグレードした。

手順は基本的にいつもお世話になっている「山下康成の”ハックしよう”」のサイトに掲載されている「ハックキットを Vine 3.1 にアップデートしよう」を参考にした。

だが、アップグレード作業を開始する”rpm -Uvh *.rpm“のコマンドを実行したところ…

待った!

「依存性の欠如」によって開始できない・・・
ここは思い切って"-nodeps“オプションを付けて再実行。

ちょっと状況は変わった。こんどはパッケージ内のファイルが重複しているようだ。

くらえ!

すかさずオプション”-force“を付加。
・・・
・・・
・・・
無事にアップグレード完了。

あとは素直にアップデート。

んで、MySQL導入。

問題ない。

さて、これから諸設定をせねばな。